Jump to content


Engine Gripes


  • Please log in to reply
6 replies to this topic

#1 vindi93

vindi93
  • Full Membership
  • 622 posts
  • Car:focus mk3 1.6 ecoboost 180bhp

Posted 25 July 2016 - 08:50 PM

Ok so here goes on Saturday I'm returning home and accelerate down dual carriageway no issues, come down slip road to island and start to hear an odd noise like clanking noise at first I thought it maybe something had come loose on roll bar as that was last thing I messed with. As it was late decided to investigate the following day, as I had to go and retrieve my jack got in the car started it up. Heard the noise again this time I'm stationary clearly nothing suspension related. Lifted bonnet and sounded not got sporadic clunking noise like metal against metal towards left hand side of engine. Drove to ford dealer on driving there it shut up on its own couldn't replicate noise when I got there. So went away drove round Sunday no issues, Monday morning over take someone drop off the speed then engine malfunction service now appears. Switch of engine start off again and drives ok to work. On way home after about 5 miles same thing happens again warning. Also car now feels sluggish. I've left it garage but I'm guessing something to do with variable timing?

#2 vindi93

vindi93
  • Full Membership
  • 622 posts
  • Car:focus mk3 1.6 ecoboost 180bhp

Posted 26 July 2016 - 06:38 PM

Well it appears the engine is over boosting according to diags so I'm guessing wastegate  issue we wait and see.

#3 vindi93

vindi93
  • Full Membership
  • 622 posts
  • Car:focus mk3 1.6 ecoboost 180bhp

Posted 31 July 2016 - 09:07 AM

Update new turbo required will get car back on Monday, at least I should get to ford fair now lol.

#4 Mike11

Mike11

    SMT & Facebook Guru

  • Administrators
  • 13915 posts
  • LocationLive~Manchester Work~Glasgow
  • Car:'54 ST170 & '17 Fiesta 140

Posted 31 July 2016 - 11:42 AM

Bit pricey before ford fair but at least you have it fixed.

#5 vindi93

vindi93
  • Full Membership
  • 622 posts
  • Car:focus mk3 1.6 ecoboost 180bhp

Posted 01 August 2016 - 05:17 PM

New turbo replaced all is well again thank I took out the autogard warranty didn't cost me a thing result. Would have cost me £1088 altogether

#6 Mike11

Mike11

    SMT & Facebook Guru

  • Administrators
  • 13915 posts
  • LocationLive~Manchester Work~Glasgow
  • Car:'54 ST170 & '17 Fiesta 140

Posted 01 August 2016 - 09:23 PM

Good job you did buy it then.

#7 firefly

firefly
  • Registered Users
  • 1034 posts
  • LocationDerbyshire
  • Car:Ford Focus ST170

Posted 01 August 2016 - 09:32 PM

That's very lucky!