Jump to content


Noisy/stiff Steering - Under 16K Miles


  • Please log in to reply
4 replies to this topic

#1 HighlanderUK

HighlanderUK
  • Full Membership
  • 732 posts
  • LocationAberdeen, Scotland
  • Car:MK3 TDCi 2.0 (185) ST-3

Posted 09 August 2014 - 04:56 PM

Anyone know what would cause a stiff bearing burring like noise / when doing full left/right lock, car drives ok, but usual micro movements of wheel when driving is stiff/jerky.

Car has done almost 16k miles (62 plate), and is not due for its annual service until September, and it's not had its 12.5k service yet.

This started last night on the drive home from work, was fine yesterday morning.  Possible issue with power steering???  

Local garage/dealer I use said they have no techs in until Monday.

#2 JezzaW

JezzaW
  • Registered Users
  • 32 posts
  • LocationSomerset
  • Car:2012 focus Titanium 1.6 tdci

Posted 09 August 2014 - 09:46 PM

Surely the service should have been at 12.5k?

Could be a problem with any warranty claim

#3 EcoMatt

EcoMatt
  • Registered Users
  • 146 posts
  • LocationNewark, Nottinghamshire
  • Car:Focus 1.6 Ecoboost Titanium

Posted 10 August 2014 - 09:36 PM

I cant see it being a problem with warranty as I service the car myself with Ford parts, no proof of when I serviced the car and they still honoured the warranty.  Id book it in and get it looked at.

#4 HighlanderUK

HighlanderUK
  • Full Membership
  • 732 posts
  • LocationAberdeen, Scotland
  • Car:MK3 TDCi 2.0 (185) ST-3

Posted 11 August 2014 - 09:54 PM

View PostJezzaW, on 09 August 2014 - 09:46 PM, said:

Surely the service should have been at 12.5k?

Could be a problem with any warranty claim

wouldn't think there would be a warranty issue, already had the gearbox/clutch replaced no bother.

full service is costly and we have been away on holiday with the car which has piled on the extra miles, plus a family member in hospital, so nightly trips up there for the last week or so.  

will get the car booked in for the service in a few weeks and they can look at it then.  cheers.

#5 Ldsundance

Ldsundance
  • Full Membership
  • 5033 posts
  • LocationNewcastle Upon tyne
  • Car:mk3 titanium x navigator

Posted 31 December 2016 - 04:03 PM

did you get this fixed? was it the strut top bearings?